What iOS Version and Hardware Runs Game of Thrones Ascent?

Game of Thrones Ascent was built to support these minimum system requirements:

  • iOS 6.0 and higher.
  • iPhone 4 and higher.
  • iPad 2 or iPad Mini and higher.

For best performance, we recommend an iPhone 5 with iOS 7, or an iPad 4 with iOS 7.

Have more questions? Submit a request

Comments

Powered by Zendesk